All orders placed will be shipped out as usual, but delivery times are expected to be affected due to COVID-19. Thanks for your continued support with Geekworm. Read More
New X832 and X735 setup issues | Geekworm

New X832 and X735 setup issues


  • I'm new to using geekworm products, but decided to try out an X832 (single 3.5" HDD board) with X735 (power management board) with a raspberry pi 4 (4GB model), inside of the geekworm case. I also ordered the geekworm official power supply (DC 5V 4A Official Power adapter)

    After getting everything assembled and connected. Upon initial power on, I noticed two issues immediately:

    1) constantly getting the low voltage notification

    2) connected HDD (WD Red 4TB, model WD40EFRX) is not recognized by system.

     

    Can anyone offer any insight, recommendations, solutions for the two (I assume separate, but potentially related) issues?



  • I think I answered my own question in my OP, but I just realized while I was troubleshooting on my own, that the power supply I purchased is only 5V (actually indicates it can supply up to 8V on the unit itself)...and the power input on the X832 board clearly states 12V...so that's obviously why I'm getting the low voltage and has got to be the reason that the HDD is not being recognized. When I took the assembly out of the case and had it sitting on the desk, even after powering on I heard no movement of the HDD. Anyways, I'll order a 12V PSU and again. 

     

    I just wish that Geekworm had a PSU clearly advertised on their amazon page.


  • @Daniel Hogan Hi dear ,thanks  for your effort and advice ,We will improve the information on Amazon

    Sincerely 

    Geekworm


  • I'm having similar issues, but I don't think PSU voltage is the root in my case. I bought the kit that includes X832, metal case and 12V@5A PSU, therefore I assume voltage issues are out of question here, however, I've tried with two different HDDs, and none is detected by the system, even though I've used one of them with the Pi for 3 years now, any ideas?


  • hi, Please refer to :


  • That is exactly the way I'm using it, except I don't have the X735. I thought the USB jumper might be the problem, so I ordered a male-male cable from amazon, and it still doesn't detect the drive. I've tested the drive alone on a Windows PC and it worked fine, and also tested the drive with another SATA-USB3 mounting, and it worked fine with the raspi4, so I'm guessing the problem has to do with the way the X832 comunicates with the raspi4.


  • I've been able to pinpoint a possible cause, whenever I power the RasPi4 with the X832 and the provided cable, the HDD is not detected. If that cable is disconnected and I use the USB-C power supply for the RasPi, it works perfectly. Is it possible that I'm using an incorrect power output from the X832?


Please login to reply this topic!
BACK TO TOP