Raspberry Pi Voice HAT LED not working | Geekworm

Raspberry Pi Voice HAT LED not working

  • Hello,

    I'm using the Voice HAT Voice_HAT

    Speaker and Micro are working with seeespeeker Software. 
    (Raspberry 3, Raspberry Pi 3A+, Buster)

    LEDs are not working. Green LED is permanently ON.

    I tried the Voice_HAT_Software

        sudo python pixels.py

    -> No LED [Software gives no Error, added print("something") after pixels.wakeup() ]
    Also tried other Software, which works with respeaker 4-mic array.

    Same result at friend, who bought same model.

    Help needed.




  • Hi, 


    1. Do you use other GPIO pins?

    2. Could you provide more details such error snapshot or other photos?


  • @Harry Huang 

    No other GPIOS used. Fresh installed buster.

    Which kind of errors? pixels.py runs and prints whatever I want. SPI is activated.

    I will try to watch syslog and post it later.

    thank you

  • @Harry Huang 

    Fresh installed:

    • OS Buster (update + dist-upgrade)
    • git 
    • seeed-voicecard
    •  pip, spidev
    • SPI enabled
    • Voice-Hat (download + unzip)

    sudo python pixels.py


    spidev spi0.1: zero-length SPI transfer ignored

    And, of cause: NO LED

  • hi,


  • @Harry Huang 

    Thanks for your reply.


    It looks like. Someone from rhasspy community bought the same HAT with same problems

  • @kay koch This board does not use standard GPIO pins. It uses MOSI = GPIO23, SCLK = GPIO24. Documentation is close to non existing, but I found this one that works: https://github.com/u-geek/RaspiVoiceHAT

    I'm using it to create a skill for Mycroft. Not finished yet:


Please login to reply this topic!